Bermain-main dengan Mikrotik Script

Baru ada kesempatan buat postingan. Kali ini saya mencoba mengumpulkan beberapa script  sederhana di mikrotik yang pernah saya gunakan.

1. Menghapus semua rule firewall

/ip firewall filter remove [/ip firewall filter find]

2. Men-disable rule yang aktif (berdasarkan komentar)

Script ini akan men-disable semua rule aktif yang memiliki komentar "ruleSatu"

:local komentar "ruleSatu"
/ip firewall mangle disable [/ip firewall mangle find disabled=no && comment=$komentar];
Jika ingin mendisable semua rule yang aktif, ubah menjadi

/ip firewall mangle disable [/ip firewall mangle find disabled=no];

3. Meng-enable rule yang tidak aktif

:local komentar "ruleDua"
/ip firewall mangle enable [/ip firewall mangle find disabled=yes && comment=$komentar];
Jika ingin meng-enable semua rule yang tidak aktif, ubah menjadi

/ip firewall mangle enable [/ip firewall mangle find disabled=yes];

4. Memblokir semua ip yang akan mengakses servis-servis yang ada

Rule ini akan membuat address list IP (contoh 10.10.11.11) yang berhak mengakses servis-servis yang ada seperti WINBOX, FTP, SSH dan sebagainya, dan kemudian akan meblokir IP selain yang didaftarkan.
 
/ip firewall address-list
add list=ip-manajemen address=10.10.11.11
 
/ip firewall filter
add chain=input src-address-list=ip-manajemen protocol=tcp dst-port=21,22,23,80,443,8291 action=accept
 
add chain=input protocol=tcp dst-port=21,22,23,80,443,8291 action=drop

5. Mengecek Port yang bervirus

Rule ini akan mengizinkan 5 paket per detik, dengan burst 10 untuk koneksi baru. Rule mangle nya akan menambahkan pada ip address list, jike ada melebihi batas tersebut. Cara ini lumayan efektif untuk memblokir semacam virus atau worm yang mengirimkan paket dalam jumlah yang banyak. Selanjutnya tinggal melihat IP client, kali aja PC nya perlu dibersihkan dari virus :)
 
/ip firewall mangle
add action=add-src-to-address-list address-list=Worm-445 address-list-timeout=1h chain=prerouting connection-state=new disabled=no dst-port=445 limit=5,10 protocol=tcp
 
/ip firewall filter
add action=drop chain=forward disabled=no dst-port=445 protocol=tcp src-address-list=Worm-p445
add action=drop chain=forward disabled=no dst-port=445 protocol=tcp src-address-list=Worm-p445

6. Memblokir Winbox Discovery (Membatasi Akses Winbox)

Winbox/Mikrotik memiliki fitur discovery (yang akan menampilkan daftar Hardware Mikrotik, beserta IP dan MAC Address-nya. Hal ini cukup membantu jika Administrator lupa IP interface untuk masing-masing perangkat. Tetapi bisa juga menjadi celah bagi orang jahil, yang ingin mencoba login ke Mikrotik. Untuk itu, script di bawah ini bisa digunakan untuk memblokir Winbox Discovery Mikrotik.

 
/tool mac-server
add disabled=yes interface=all
/tool mac-server ping
set enabled=no
 
/ip firewall filter
add action=drop chain=input comment="block mikrotik discovery" disabled=no dst-port=5678 protocol=udp
add action=drop chain=input comment="ALL WINBOX REQUEST By MAC Address" disabled=no dst-port=20561 protocol=udp
add action=drop chain=input comment="ALL WINBOX REQUEST EXCEPT FROM MY PC" disabled=no dst-port=8291 protocol=tcp src-address=!192.168.2.6

Segitu dulu main-main dengan script Mikrotik, akan ditambahkan pada postingan selanjutnya. Semoga bermanfaat, (z)