Membatasi Jumlah Download Thread IDM

IDM, senjata utama para downloader, tentunya menjadi momok bagi para pemilik ISP (baca: warnet, hotspot). Bukannya apa, satu orang yang download, bisa "merebut" jatah orang lain. Sehingga, ujung-ujungnya adalah komplain di sana sini.
Dengan membuat limiter pada mikrotik, maka akan lebih "memperkecil" jatah yang direbut tadi.
Tetapi, masalah bukan sampai di situ saja, dengan adanya situs-situs download yang membolehkan multi-thread download, maka "seakan-akan" limiter yang dibuat tidak "berfungsi dengan semestinya".
Masalah ini mungkin (baca: saya sendiri belum coba :D) bisa diatasi dengan melimit jumlah multi-thread yang dibuka pada saat proses download.

/ip fi fi add chain=forward connection-state=new src-address-list=ip-client connection-limit=2,32 action=accept;
/ip fi fi add chain=forward connection-state=new src-address-list=ip-client action=drop;


Rule tersebut akan meng-drop semua koneksi multi-thread yang lebih dari 2.

Atau mungkin bisa dikembangkan juga dari kode berikut:


/ip firewall layer7-protocol
add comment="" name=EXE regexp="^.*get.+\\.exe.*\$"

/ip firewall mangle
add action=mark-connection chain=prerouting comment="" disabled=no layer7-protocol=EXE new-connection-mark=download_conn passthrough=yes protocol=tcp



/ip firewall filter
add action=tarpit chain=forward comment="Limit Download Conn" connection-limit=9,32 connection-mark=download_conn disabled=no in-interface=ether3-client protocol=tcp  



(sumbernya: http://www.forummikrotik.com/general-networking/21386-cara-ngebatesin-receiving-data-di-idm.html)